Perintah Dasar Mikrotik CLI-Command Line Interface Berikut Penjelasannya

Untuk mengkonfigurasi Mikrotik Router ada beberapa cara yang bisa kita gunakan, yaitu melalui aplikasi Winbox GUI dan ini yang sering saya pakai, melalui web browser (tampilan menunya mirip dengan winbox dan tentu saja router minimal harus sudah mempunyai IP Address) dan konfigurasi mikrotik router dengan menggunakan perintah CLI atau Command Line Interface.

Mengkonfigurasi Mikrotik dengan mengetikkan perintah CLI memang lebih menantang daripada lewat Winbox atau browser karena minimal kita harus mengetahui logika atau susunan baris perintahnya. Tetapi mengkonfigurasi Mikrotik menggunakan CLI ini mempunyai beberapa kelebihan, diantaranya untuk mengakses Mikrotik-nya bisa dengan menggunakan telnet, ssh, kabel serial, menu terminal pada winbox atau secara langsung apabila MikroTik RouterOS kita install pada sebuah komputer atau virtual PC.

Tampilan awal Terminal dalam Winbox

Dalam kesempatan kali ini, kita akan melakukan konfigurasi dasar pada Mikrotik dengan menggunakan perintah dasar CLI. Sebagai bahan percobaan / labs, disini saya menggunakan Mikrotik RouterBoard 751U 2HnD dengan MikrotikOS versi 6.45.6 dengan konfigurasi yang telah saya reset sebelumnya (No Default Configuration).

Perintah Dasar Mikrotik CLI yang Sering Digunakan

1. Memberi Nama / Set Identity Router

/system identity set name=PCNetLabs

2. Set Time Zone, Tanggal dan Waktu di Mikrotik

Untuk seting tanggal dan waktu pada Mikrotik bisa dilakukan secara manual atau secara otomatis menggunakan NTP Server. Karena Mikrotik belum terhubung ke Internet, maka disini kita akan set secara manual terlebih dahulu.

/system clock 
set time-zone-autodetect=no
set time-zone-name=Asia/Jakarta
set date=oct/05/2019
set time=21:32:00

3. Memberi Nama Interface Mikrotik

Interface atau penghubung merupakan mekanisme komunikasi antara user dengan sistem. Pada Mikrotik terdapat beberapa interface seperti ethernet, wireless, bridge dan sebagainya. Misalnya secara default ether port 1 pada mikrotik diberi nama ether1, karena nantinya port ether1 akan terhubung ke Internet, maka kita akan menggantinya menjadi ether1-internet

/interface ethernet set ether1 name=ether1-internet

4. Membuat Interface Bridge di Mikrotik

Bridge pada Mikrotik adalah interface virtual yang akan kita buat dan digunakan untuk menggabungkan 2 atau lebih interface sehingga interface-interface tersebut seolah-olah berada pada 1 segmen jaringan yang sama. Proses penggabungan ini terjadi pada layer data link, sehingga nantinya Interface bridge yang kita buat akan mempunyai 1 Mac Address.

Disini kita akan menggabungkan ether2 s/d ether5 kedalam sebuah interface bridge yang kita beri nama bridge1-LAN.

/interface bridge add name=bridge1-LAN

/interface bridge port
add bridge=bridge1-LAN interface=ether2
add bridge=bridge1-LAN interface=ether3
add bridge=bridge1-LAN interface=ether4
add bridge=bridge1-LAN interface=ether5

Untuk melihat konfigurasi interface bridge yang telah kita buat, kita bisa mengeceknya dengan perintah:

interface print
interface bridge print
interface bridge port print

5. Menambahkan Interface List di Mikrotik

Interface list digunakan untuk memudahkan managemen interface yang ada. Misalnya disini kita akan menambahkan Interface List dengan nama WAN, yang nantinya berisi Interface yang akan terhubung ke jaringan publik / Internet dan Interface List dengan nama LAN, yang nantinya akan berisi interface-interface yang akan terhubung ke jaringan lokal / LAN.

/interface list 
add name=WAN comment="WAN Interface"
add name=LAN comment="LAN Interface"

Selanjutnya kita akan memasukkan bridge1-LAN ke interface list LAN dan ether1-internet ke list WAN.

/interface list member
add interface=bridge1-LAN list=LAN
add interface=ether1-internet list=WAN

6. Set IP Address pada Interface Mikrotik

Dari langkah yang telah kita lakukan diatas, sekarang kita sudah mempunyai Interface bridge1-LAN dan ether1-internet selanjutnya adalah memberikan IP Address pada masing-masing Interface tersebut.

/ip address 
add address=172.16.88.1/24 interface=bridge1-LAN
add address=192.168.1.10/24 interface=ether1-internet

Apabila kita ingin merubah IP Address yang telah diset sebelumnya maka terlebih dahulu kita harus menghapus IP Address yang lama terlebih dahulu, caranya adalah seperti pada contoh dibawah:

/ip address 
remove 0
add address=172.16.1.1/24 interface=bridge1-LAN
perintah dasar mikrotik cli set ip address

7. Set Gateway / Default Rute

Supaya Mikrotik bisa terhubung ke Internet maka kita harus set IP Address Gateway dan DNS. Gateway adalah IP Address yang pertama kali harus kita lewati sebelum terhubung ke jaringan lain, misalnya apabila kita menggunakan Modem Indohome, maka IP Address yang kita gunakan sebagai Gateway adalah IP Addressnya router Indihome, biasanya adalah 192.168.1.1/24.

/ip route add gateway=192.168.1.1

8. Set DNS Server dan DNS Cache Mikrotik

DNS Server adalah Server yang berfungsi untuk mengubah nama domain ke IP Address. Kita bisa menggunakan IP Address dari public DNS Server seperti 8.8.8.8 punya Google atau biasanya di router sendiri sudah diaktifkan fitur dns cache-nya sehingga kita juga bisa set IP Address router Indihome sebagai DNS Server pada Mikrotik yang kita seting.

Pada setingan Mikrotik ini kita akan menggunakan IP Address dari DNS Server milik OpenDNS, yaitu 208.67.222.222 dan 208.67.220.220. Dan kita set remote-request=yes agar nantinya komputer dalam jaringan LAN bisa menggunakan IP Address Mikrotik kita sebagai DNS Server-nya.

/ip dns 
set servers=208.67.220.220,208.67.222.222
set allow-remote-requests=yes

9. Set DHCP Server dan IP Pool pada Mikrotik

DHCP (Dinamyc Host Configuration Protocol) Server berguna untuk memberikan IP Address secara otomatis pada komputer client. Pada Mikrotik untuk seting DHCP server dengan CLI ini sangat simple, karena kita akan dibantu dengan wizard. Disini kita seting IP Address yang akan diberikan ke client yang terhubung ke Interface Bridge1-LAN (port2-port5) adalah mulai dari 172.16.1.10-172.16.1.100 dengan subnet mask kelas C (255.255.255.0), IP Gateway dan DNS kita set 172.16.1.1

ip dhcp-server setup 

10. Set NAT Masquarade

Peritah dasar mikrotik berikutnya adalah seting NAT Masquerade, setingan ini bertujuan agar komputer client pada jaringan private (LAN) bisa terhubung ke jaringan Public (Internet).

Masquerade merupakah salah satu bentuk NAT (Network Address Translation) yang akan menyamarkan / menggantikan IP Address local, sehingga kalau dilihat dari jaringan Public atau Internet yang terbaca adalah IP Address Public dari Router yang digunakan.

Kalau kita ingin melihat IP Address Public yang sedang kita gunakan, bisa buka url https://whatismyipaddress.com/. Disitu akan terlihat keterangan tentang IP Address dan ISP (Internet Service Provider) yang kita gunakan.

/ip firewall nat add chain=srcnat src-address=172.16.1.0/24 out-interface=ether1-internet action=masquerade

11. Backup & Restore Setingan Mikrotik

Perintah untuk mem-backup dan me-restore setingan mikrotik merupakan perintah dasar mikrotik yang harus kita ketahui, karena akan memudahkan nantinya kalau suatu saat kita akan mereset Mikrotik. Dengan mempunyai backup setingan, maka apabila suatu saat diperlukan kita tinggal me-restore-nya tanpa harus memulai konfig dari awal.

Berikut cara membackup konfigurasi system pada Mikrotik

/system backup save name="basic-config-051019"

Untuk merestore file hasil backup, gunakan perintah restore seperti berikut:

/system backup load name="basic-config-051019"

Sebagai catatan, apabila kita akan me-restore konfigurasi Router ini pada Routerboard yang lain maka disarankan Routerboard tersebut memiliki seri dan tipe-nya yang identik dengan Router asalnya.

12. Export & Import Setingan Mikrotik

Selain dengan fitur backup system, pada mikrotik juga kita bisa meng-export setingan konfigurasi dengan perintah Export. Apabila perintah backup digunakan untuk menyimpan seluruh konfigurasi system, maka dengan perintah export ini kita bisa memilih untuk meng-export sebagian parameter yang kita inginkan.

Berikut contoh perintah export pada Mikrotik

export file=all-config
ip firewall export file=firewall-config-only

Untuk meng-import file konfigurasi bisa dilakukan dengan perintah import file-name seperti dibawah:

import file-name=firewall-config-only.rsc

Demikianlah beberapa setingan dasar Mikrotik yang menggunakan Perintah Dasar CLI – command line interface Mikrotik yang telah kita buat, semoga ada manfaatnya.

Leave a Reply

Your email address will not be published. Required fields are marked *